Opened 7 years ago

Closed 7 years ago

#14845 closed defect (worksforme)

Crashes Firefox 10.0.2

Reported by: Michael Wu Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I've found a way to crash Firefox 10.0.2.

When dojoConfig.packages is not set properly and a corresponding package is requested in require() with "dojo/ready", Firefox 10.0.2 crashed.

Simply open the following web page in Firefox and it will crash. http://dev.witness24.com/~michael/dojo-test-firefox-crash/

I've also reported this problem to Firefox through Mozilla Crash Reporter.

<!DOCTYPE html>
<html>
    <head>
        <title>Test case for Dojo defect #14841</title>

        <link rel="stylesheet" href="http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dijit/themes/claro/claro.css" media="screen">
        <script type="text/javascript">
            dojoConfig = {
                packages: [
                    {name: 'test', location: '/some-invalid-location'}
                ],
                parseOnLoad: false
            };
        </script>
        <script src="http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js" type="text/javascript"></script>
        <script type="text/javascript">

            require(["dojo/ready", "test/some-package"],
                function(ready, TestWidgetA) {
                    alert("Firefox 10.0.2 will crash!!"); // Never shown
            });
        </script>
    </head>
    <body>
        <div id="mainDiv"></div>
    </body>
</html>

Change History (4)

comment:1 Changed 7 years ago by cjolif

It does not crash in 10.0.1. Note that it does not display the alert either but the console contains the following trace:

GET http://dev.witness24.com/some-invalid-location/some-package.js
	
404 Not Found	669ms	
dojo.js (line 15)
"NetworkError: 404 Not Found - http://dev.witness24.com/some-invalid-location/some-package.js"
some-package.js
xhrFailed
[Break On This Error] 	

...;};var _2f6=function(i,arr){var r=arr||[];if(i){r.push(i);}return r;};var _2f7=f...

comment:2 Changed 7 years ago by Michael Wu

Thanks for the verification. I done a more detailed test. It's correct that the alert won't be displayed.

The platform that Firefox will get crashed is as following:

  1. Windows 7 x64, Traditional Chinese version
  2. Firefox 10.0.2 x64 Traditional Chinese version

I've tested on 32bit Windows XP, both English and Chinese versions and Firefox works fine.

Will setup a VM to run Windows 7/x64/English and report back.

comment:3 Changed 7 years ago by Michael Wu

Can't reproduce on any of the following "cleanly" installed platform:

  1. Windows 7/64bit/English + Firefox 10.0.2 both Chinese/English?
  2. Windows 7/64bit/Chinese + Firefox 10.0.2 both Chinese

Not sure why it crashes my current platform. Seems like not related to dojo.

comment:4 Changed 7 years ago by cjolif

Resolution: worksforme
Status: newclosed

Ok, as it seems unrelated, I'm closing this. Please re-open if you have some indications this might come from Dojo?

Note: See TracTickets for help on using tickets.