Opened 7 years ago

Closed 7 years ago

#14843 closed feature (fixed)

TooltipDialog: doesn't layout properly with "ActionBar"

Reported by: Kitson Kelly Owned by: bill
Priority: undecided Milestone: 1.8
Component: Dijit Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

The dijit/TooltipDialog doesn't layout properly when using the ActionBar feature and gets "cut off" at the bottom (at least in claro).

A working JSFiddle demonstrating the issue is here: http://jsfiddle.net/kitsonk/q2hYU/

I don't know if the ActionBar is designed to work with the TooltipDialog, but it is a handy visual element that I think is suitable.

Attachments (1)

Dialog_tooltip_actionbar_claro.patch (1.2 KB) - added by Kitson Kelly 7 years ago.
claro patch for ActionBar? with TooltipDialog?

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by bill

Summary: dijit/TooltipDialog doesn't layout properly with "ActionBar"TooltipDialog: doesn't layout properly with "ActionBar"
Type: defectfeature

Right, ActionBar is only intended for use with Dialog, although if you have a patch to make it work with TooltipDialog too we could add it.

Changed 7 years ago by Kitson Kelly

claro patch for ActionBar? with TooltipDialog?

comment:2 Changed 7 years ago by Kitson Kelly

I have attached a patch for the .css and the .less so that ActionBar works with TooltipDialog under claro.

comment:3 Changed 7 years ago by bill

Milestone: tbd1.8
Owner: set to bill
Status: newassigned

OK thanks, I'm not sure if I like how an ActionBar looks in a TooltipDialog but I guess we should give users the option, pluswhich it gives a consistent LnF with Dialog, which is good. I'll check this in.

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [27963]:

Ability to use dijitDialogActionBar CSS section within a TooltipDialog (in addition to a Dialog), thanks Kitson! Fixes #14843.

Note: See TracTickets for help on using tickets.