Opened 8 years ago

Closed 8 years ago

#14838 closed defect (duplicate)

dijit focus manager event firing order / delay

Reported by: rradian Owned by: rradian
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

please see the attached html file.

4 dijit boxes 4 input boxes

the onfocus of the 3rd field of each set sets the focus back to field 1 the handlers are all set in markup but using connect for the dijits yields identical results

tabbing thru the dijits yields:

d1 dFocus:
d1 dBlur Beg:
d1 dBlur End:
d2 dFocus:
d2 dBlur Beg:
d2 dBlur End:
d3 dFocus:
d3 dBlur Beg:
  d4 dBlur Beg:
  d4 dBlur End:
  d1 dFocus:
d3 dBlur End:
d4 dFocus: (the focus does end up on field 1 though)

tabbing thru the html inputs yields:

h1 hFocus:
h1 hBlur: Beg
h1 hBlur End:
h2 hFocus:
h2 hBlur: Beg
h2 hBlur End:
h3 hFocus:
h3 hBlur: Beg
  h1 hFocus:
h3 hBlur End:

changing a value in the first dijit box yields:

d1 dFocus:
d1 dBlur Beg:
d1 dBlur End:
d2 dFocus:
d1 dChange:

changing a value in the first html box yields:

h1 hFocus:
h1 hChange:
h1 hBlur: Beg
h1 hBlur End:
d1 dFocus:

the dijit firing order makes it impossible to enforce strict navigation rules based on field (or other) values or outcomes

Attachments (1)

t1.html (2.7 KB) - added by rradian 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by rradian

Attachment: t1.html added

comment:1 Changed 8 years ago by bill

Description: modified (diff)
Owner: set to rradian
Status: newpending
Summary: dijit event firing orderdijit focus manager event firing order / delay

This deals with the focus manager (dijit/focus.js). Probably you want to connect to the actual focus/blur events on the widget. Does connecting for focus and blur on widget.focusNode (instead of widget) fix your problem?

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by bill

Resolution: invalid
Status: closedreopened

comment:4 Changed 8 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Duplicate of #13341.

Note: See TracTickets for help on using tickets.