Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#14832 closed defect (duplicate)

i18n.js and locale files ALWAYS loaded via XHR despite being in a build

Reported by: Karl Tiedt Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: BuildSystem Version: 1.7.2
Keywords: Cc: Patrick Ruzand
Blocked By: Blocking:

Description

"dojo/i18n" regardless of being in a build, will never get loaded from the layer cache -- this can be seen via the Dojo Boiler Plate code (full AMD) -- it also fails in legacy + AMD just for the record

In addition to this it loads via XHR not script injection and subsequent NLS files are loaded via XHR

If a locale NOT in the build is requested, the page fails to load due to a 404 request that blocks page loading -- which my understanding should never happen with the new build system (spurious 404 requests for locale files)

Change History (7)

comment:1 Changed 8 years ago by Karl Tiedt

I will try and get my test case up this weekend, work kept delaying me this afternoon.

comment:2 in reply to:  1 Changed 8 years ago by Rawld Gill

Replying to ktiedt:

I will try and get my test case up this weekend, work kept delaying me this afternoon.

I believe [28049] may solve this problem. Can you try it with your use case and let me know what you see. Thanks!

comment:3 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:4 Changed 8 years ago by Patrick Ruzand

Cc: Patrick Ruzand added

comment:5 Changed 8 years ago by Rawld Gill

Resolution: duplicate
Status: assignedclosed

The root cause of the problem is identical to that identified to #14092. I verified the error in 1.7.2 and the fix in trunk as contained in #14092#comment:16.

Closing this as duplicate and will track in #14092.

comment:6 Changed 7 years ago by danielm

Hello,

Still got this issue in 1.8.0: flattened nls resource(s) is/are loaded, but not used and i18n.js still loads the separate resources and uses these.

Was this fix also fixed in this version or only the 1.7.X versions?

Thanks!

comment:7 Changed 7 years ago by bill

I show the code in 1.8.0 too. Do you have a test case that fails? Does the Dojo Boiler Plate code work for you?

Note: See TracTickets for help on using tickets.