Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14829 closed defect (fixed)

legacy build + 1.7.x outputs no _ROOT.js NLS files

Reported by: Karl Tiedt Owned by: Rawld Gill
Priority: undecided Milestone: 1.8
Component: BuildSystem Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Prior to 1.7 a build produced [module]/nls/[layer name]_ROOT.js files that were fallback files when a page was loaded and requested a non supported language pack...

This appears to not be happening with 1.7+

If this is "by design" it is not documented anywhere in the release notes or build docs that I searched

Change History (2)

comment:1 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

You are correct that this was not documented. The short answer is that the layer includes the root bundle.

The slightly longer answer is now documented here:

http://livedocs.dojotoolkit.org/build/transforms/writeAmd#nls-bundles

comment:2 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.