Opened 8 years ago

Closed 7 years ago

#14827 closed defect (fixed)

Fails to hide address bar on some Android devices

Reported by: Atsushi Ono Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version:
Keywords: Cc: Eric Durocher
Blocked By: Blocking:

Description

With the latest 1.8 code on dojo trunk, hideAddressBar does not work on some Android devices such as Galaxy SII.

Attachments (1)

14827.patch (2.6 KB) - added by Atsushi Ono 8 years ago.
[patch][ccla] fix for failing to hide address bar on Android

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Atsushi Ono

Attachment: 14827.patch added

[patch][ccla] fix for failing to hide address bar on Android

comment:1 Changed 8 years ago by Atsushi Ono

Attached a patch to fix the issue. The root cause of this issue seems to depend on devices as follows:

  • On some Android devices such as Galaxy SII, both "innerHeight" and "outerHeight" sometimes return 0 during hideAddressBar, so retry it after a while.
  • On some Android devices such as HTC EVO, "outerHeight/devicePixelRatio" is not enough height to hide address bar, so use larger value such as "outerHeight" instead.

comment:2 Changed 8 years ago by ykami

In [28096]:

Refs #14827 !strict Android workaround. Applied a patch from onoat. Thanks onoat for the patch.

comment:3 Changed 7 years ago by Eric Durocher

Cc: Eric Durocher added

comment:4 Changed 7 years ago by ykami

Milestone: tbd1.8
Priority: undecidedhigh
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.