Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1482 closed defect (wontfix)

PopupMenu2 context menu is browser context menu

Reported by: guest Owned by: liucougar
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

When a widget-based (i.e. contextMenuForWindow=false) PopupMenu2 is displayed, right-clicking the popup brings up the browser's context menu. Shouldn't this be suppressed?

Dojo 0.3.1, w/ Firefox 1.5.0.6 & Mozilla 1.7.13

Change History (9)

comment:1 Changed 13 years ago by bill

Resolution: worksforme
Status: newclosed

comment:2 Changed 13 years ago by liucougar

Milestone: 0.4
Resolution: worksforme
Status: closedreopened

I can reproduce this in IE and FF

comment:3 Changed 13 years ago by liucougar

Owner: changed from bill to liucougar
Status: reopenednew

comment:4 Changed 13 years ago by liucougar

severity: normalminor

comment:5 Changed 13 years ago by liucougar

Resolution: wontfix
Status: newclosed

this issue will not be fixed, as it is minor and it opens up the possibility of contextmenu for contextmenu support

comment:6 Changed 13 years ago by guest

Actually, I was expecting that the browser's default contextmenu would not be displayed when in the dojo contextmenu.

Does this mean I need to add a handler to every PopupMenu2 instance I create that cancels the event if I want to stop this from happening? Seems like something the toolkit could do with very little effort. Something that just calls preventDefault() on the 'oncontextmenu' event for the popup. Or am I missing something?

comment:7 Changed 13 years ago by bill

It seems you are right-clicking an object to get a context menu, but then for some reason you are right-clicking AGAIN. We don't expect any users to do that, so that's why we didn't think it was worth doing anything. I'm not sure if it's a bug or not, but it doesn't seem like an important issue. Why would someone right-click on a context menu? It seems strange to me.

comment:8 Changed 13 years ago by guest

The reason? User interaction testing & hard won experience.

1) The behavior is different from when the contextmenu is for the window.

2) If a regular user does perform a second right-click they will get confused, especially if the window's contextmenu is not the default browser contextmenu.

3) More importantly, is the window contextmenu relevant when an inner node's contextmenu is active?

comment:9 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.