Opened 7 years ago

Closed 6 years ago

#14802 closed defect (fixed)

[regression] exception about widget.get when drawing

Reported by: bill Owned by: Mike Wilcox
Priority: undecided Milestone: 1.9
Component: DojoX Drawing Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Starting from 1.6 I get an exception about widget.get undefined when trying to draw anything in test_drawing.html or test_drawing_toolbar.html.

The problem is that the dijit FocusManager code sees a widgetid attribute for the DOMNode for dojox.drawing.Drawing "widget", but that widget doesn't have a get() method because it doesn't extend _WidgetBase.

Change History (3)

comment:1 Changed 7 years ago by Colin Snover

Status: newopen

comment:2 Changed 7 years ago by bill

#15929 is a duplicate of this ticket.

comment:3 Changed 6 years ago by dylan

Milestone: tbd1.9
Resolution: fixed
Status: openclosed

Unable to reproduce in current nightly. Closing as fixed.

Note: See TracTickets for help on using tickets.