Opened 8 years ago

Closed 7 years ago

#14792 closed defect (duplicate)

staticHasFeatures doesn't support undefined values

Reported by: bill Owned by: Rawld Gill
Priority: high Milestone: 1.8
Component: BuildSystem Version: 1.7.2rc1
Keywords: Cc:
Blocked By: Blocking: #14801

Description (last modified by bill)

I'm trying to make a profile for a webkit-only mobile build. My staticHasFeatures looks like:

staticHasFeatures:{
	webkit:true,
	ie:undefined,
	mozilla:undefined,
	opera:undefined
}

ie and others are set to undefined because on a non-built dojo, has("ie") returns undefined, rather than 0 or false, so that both has("ie") < 6 and has("ie") > 8 evaluate to false.

However, the problem is that has("ie") is not getting replaced by undefined in the built version.

See attached profile for test case.

Attachments (1)

amd.profile.js (943 bytes) - added by bill 8 years ago.
not working profile

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by bill

Description: modified (diff)

Changed 8 years ago by bill

Attachment: amd.profile.js added

not working profile

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 in reply to:  description Changed 8 years ago by Rawld Gill

Replying to bill: iiuc, this is the same issue as #14286. Is that correct?

comment:4 Changed 8 years ago by bill

Woops, I don't even remember filing #14286. Well, this ticket is along the same lines, but it's concerned with the values of "undefined" rather than numbers like "7".

comment:5 Changed 8 years ago by bill

Blocking: 14801 added

comment:6 Changed 7 years ago by Rawld Gill

Milestone: tbd1.8
Priority: undecidedhigh
Resolution: duplicate
Status: assignedclosed

Duplicate of #14286

Note: See TracTickets for help on using tickets.