Opened 7 years ago

Closed 7 years ago

#14783 closed feature (invalid)

build Resource Tags vs. Transforms

Reported by: hungerburg Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: BuildSystem Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

The build system offers lots of transforms, but only a select choice of so called resource tags, to call them. I understand that the build system is smart, and knows itself most of the transforms to apply. I dont understand though, why transforms cannot explicitly requested? Eg. I would like to have a certain file in my build not just plainly copied, neither amdized, just shrinksafe/closure optimized. I understand further, that I would like the build system to perform a task, that is not strictly dojo related, because these are scripts, that are to be used with dojo available, but also without, maybe call them polyvalent.

So I suggest in addition to the copyOnly tag an optimizeOnly tag. This is trivial to implement and it would make me happy. Not a bug, also not an enhancement, but a feature.

Thank You for reading.

Kind Regards

Peter

Change History (3)

comment:1 Changed 7 years ago by ben hockey

this is something you can already do yourself if you adjust bc.transformJobs. admittedly it is not immediately evident how it works but the ability for you to write your own transform (or leverage an existing transform) that would be triggered via any condition you want (including resource tags) is something that already exists. btw, even though its not immediately evident how to do it, it is actually relatively simple to use once you figure out what's happening.

in short, the architecture of the build tool completely accommodates your feature request already but currently you need to dig into the code to figure out how to achieve this.

comment:2 Changed 7 years ago by hungerburg

Thank you neonstalwart for this tip. I must confess, that the richness in features of most of dojo will have the power to overwhelm me for some time to come. Please excuse, that I will now not try to find out how to adjust bc.transformJobs without patching dojo (within profile.js?), if this is possible at all, but explain another workaround, that makes this feature request moot:

I simply changed the legacy part of the site to load the script with plain require.js (a single line change) and made the script itself amd conformant, which proved not a lot of work. That made the build time warning go away, and it also makes the code to plug (at runtime) the script into the dojo part of the site much more clean. amd rocks!

Thank You

Peter

comment:3 Changed 7 years ago by ben hockey

Resolution: invalid
Status: newclosed

cool - i'll close this ticket.

Note: See TracTickets for help on using tickets.