Opened 8 years ago

Closed 8 years ago

#14778 closed defect (duplicate)

accordion pane does not collapse properly when startup() before adding children (IE8)

Reported by: fredfortier Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Background: I am trying to get the accordion pane to display each pane's height according to the height of the content pane that it contains. I can do this with Firefox 10, not with IE8.

Problem Statement: I found that I am obtaining the desired behavior in FF, when invoking myAccordion.startup() BEFORE adding each content pane as childred: myAccordion.addChild(myContent). In FF, if a startup AFTER, I get a fixed height. If I startup BEFORE in IE8, I get my dynamic eight but I get an "Invalid argument" JS error when clicking on a pane. Visually, the accordion pane behaves like a title pane (it does not collapse).

Change History (1)

comment:1 Changed 8 years ago by bill

Component: GeneralDijit
Resolution: duplicate
Status: newclosed

Duplicate of #11037.
Variable height panes are not supported. FYI, you can use http://docs.dojocampus.org/dojox/widget/TitleGroup to get an accordion with variable height.

Note: See TracTickets for help on using tickets.