Opened 7 years ago

Closed 7 years ago

#14772 closed defect (duplicate)

AMD loader silently fails to load resource without displaying an error message in the debug console

Reported by: Paul Christopher Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: Loader Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Description

Ok, the AMD loader is new to me. And Dojo is new to me. However I have encountered a strange behaviour which makes code difficult to debug (i.e. spot the mistake). Maybe it is a bug? Here's the full story:

Sometimes a module cannot be loaded by the loader. However there is no error message in the debug console visible. Everything seems to be ok, but your code simply does not work and you don't know why.

Steps to reproduce the issue

Run the attached test case testAMDLoader and run it with Firefox10 and Firebug 1.9.1 on Win7. The html page displays some kind of number text box widget. Using this widget, you can do simple calculation within the number box (e.g. 3+2 and when the onblur event is fired, the result is caculated). However the code does not work, because of a bug in the require statement in the file CalculationTextBox.js. But in Firefox's Firebug, there is no error message visible! Now correct the bug in CalculationTextBox.js: Replace in the define-statement "dojo/i18n!../dojo/cldr/nls/number" by "dojo/i18n!../../dojo/cldr/nls/number". The code will work now. However output in debug console will still be the same.

Discussion

These are rare cases. However, I least I think so, that I have encountered this problem several times in different constellations. The above test case is just one - the only one I could isolate so far.

Attachments (1)

testAMDLoader.zip (2.3 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Paul Christopher

Attachment: testAMDLoader.zip added

comment:1 Changed 7 years ago by ben hockey

Resolution: duplicate
Status: newclosed

this seems to be a duplicate of #14707. if that's not the case then comment again and i'll reopen the ticket.

Note: See TracTickets for help on using tickets.