Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14771 closed defect (invalid)

Dijit.form.Button, DijitDialog and Firefox 10: No focus outline visible for button if button is the first focusable element of a dialog

Reported by: Paul Christopher Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Description

If a dijit.Form.Button is the first focusable element of a dijit dialog, no focus outline is visible for this button in Firefox 10. It works like a charm in IE9, Safari 5.1.2 on Win7.

Steps to reproduce the issue

Run the attached test case testFocusOutline.html. A dijit dialog contains two buttons. The first button gets focus by default (since it is the first focusable element of the dialog). However in Firefox10, no focus outline will be visible. Now use the tab key. The next button gains focus. The focus outline for this button gets displayed correctly.

Affected versions

Firefox 10 (Win7), Dojo 1.7.1

Attachments (2)

testFocusOutline.html (971 bytes) - added by Paul Christopher 7 years ago.
testFocusOutline2.html (1016 bytes) - added by bill 7 years ago.
press tab to focus "show" button and then click it; focus on the dialog's button is then shown

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Paul Christopher

Attachment: testFocusOutline.html added

comment:1 Changed 7 years ago by bill

I wonder if FF doesn't start to show the focus outline until the user starts tabbing. (Since mouse users don't like to see the focus outline.)

comment:2 Changed 7 years ago by bill

Resolution: invalid
Status: newclosed

Yah, it's like I said above, that FF doesn't start to show focus until the user starts tabbing. (This is FF windows. On FF mac it's shown right away.)

I'll attach a modified version of your test case to show that's true. Press tab to focus the "show" button and then click it (or hit enter), and the focus on the dialog's first button will be shown.

Changed 7 years ago by bill

Attachment: testFocusOutline2.html added

press tab to focus "show" button and then click it; focus on the dialog's button is then shown

comment:3 Changed 7 years ago by Paul Christopher

Yes, you are perfectly right Bill! I didn't know, that Firefox hides the focus outline until the user tabs.

Thank you very much for looking at that! I do care about usability and accessibility a lot.

And at least I could learn this now: Sometimes it is good to reduce things in test cases, sometimes not: At least I should have given a focusable element to the body so as to be more realistic. Still learning... ;-)

comment:4 Changed 7 years ago by bill

No worries. We spend a lot of time on accessibility so it's good to see someone else interested in it.

Note: See TracTickets for help on using tickets.