Opened 10 years ago

Closed 8 years ago

#14747 closed defect (worksforme)

ValidationTextBox.html, ComboBox_a11y.html "_robot.typeKey is not a function" failures on FF10 (WinXP)

Reported by: bill Owned by: haysmark
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.1
Keywords: dohfail Cc:
Blocked By: Blocking:

Description (last modified by bill)

I get intermittent but often occurring errors on tests/form/robot/ValidationTextBox.html and tests/form/robot/!ComboBox_a11y.html about typekeys not being found. The tests that fail vary but the error is always similar to:

dojo.js (line 705) _robot.typeKey is not a function [Break On This Error]

...e), Number(keyCode), Boolean(alt), Boolean(ctrl), Boolean(shift), Boolean(meta),...

robot (line 44) _AssertFailure: http://mac.local/trunk/dojo/dojo.js:351 assertEqual() failed: expected -123.00 but got - with hint: focusNode.value ERROR IN: (function () {var d = new doh.Deferred;var onChange = dojo.byId("oc8");doh.robot.typeKeys("-123.00", 1000, 1400);doh.robot.sequence(d.getTestCallback(dojo.hitch(this, function () {doh.is("-123.00", this.textbox.focusNode.value, "focusNode.value");doh.is(-123, this.textbox.get("value"), "get('value')");doh.t(this.textbox.isValid(), "isValid()");})), 1500);return d;}) dojo.js (line 705) FAILED test: negative decimal 3931 ms

Attachments (1)

ComboBox_a11y.log (17.5 KB) - added by bill 10 years ago.
log from running ComboBox_a11y.html on FF10.0

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by bill

Blocking: 14570 added
Description: modified (diff)
Keywords: dohfail added

comment:2 Changed 10 years ago by bill

Description: modified (diff)
Summary: ValidationTextBox failures on FF10 (WinXP)ValidationTextBox.html, ComboBox_a11y.html "_robot.typeKey is not a function" failures on FF10 (WinXP)

Might be a problem with DOH Robot itself, but perhaps dijit can work around it.

comment:3 Changed 10 years ago by Douglas Hays

Owner: changed from Douglas Hays to haysmark
Status: newassigned

comment:4 Changed 10 years ago by bill

Blocking: 14570 removed

comment:5 Changed 10 years ago by haysmark

That sounds like the applet didn't load...

comment:6 Changed 10 years ago by haysmark

I tried running the form tests in FF10 and it worked... do you have any more specifics you can give me?

comment:7 Changed 10 years ago by bill

I know the applet loaded because most of the tests passed. I'd suggest to try running it 10 times or so and see if you can reproduce the error. Like I said, it's a timing condition, so it won't happen every time.

comment:8 Changed 10 years ago by haysmark

So you are saying you load ComboBox_a11y by itself, not in the runner, and you get that error, yet most of the tests pass?

comment:9 Changed 10 years ago by bill

Yes, I'll upload the log from firebug. Problem happened on Windows XP with FF10.0 and also FF10.0.1.

Last edited 10 years ago by bill (previous) (diff)

Changed 10 years ago by bill

Attachment: ComboBox_a11y.log added

log from running ComboBox_a11y.html on FF10.0

comment:10 Changed 10 years ago by haysmark

FF10 seems to be a common thread. I can consistently reproduce the error in Textarea. It types 4 sentences of the quick brown fox and then gives the error.

http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2/dijit/tests/form/robot/Textarea.html

comment:11 Changed 8 years ago by bill

Resolution: worksforme
Status: assignedclosed

I haven't seen this error for a while and since we will (someday) abandon doh/robot in favor of webdriver, I'm closing this ticket.

Note: See TracTickets for help on using tickets.