Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#14744 closed defect (wontfix)

Validated input inside a label tag

Reported by: Liane Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

When a validated input (NumberTextBox?, ValidationTextBox? etc...) is surrounded by a label tag, a click in the label doesn't focus the input.

Example: http://jsfiddle.net/Liane/SFGrQ/

Also, in FireFox? (10.0, Mac & PC), when the input contains a wrong value, it isn't possible to set the focus clicking inside the input: type some wrong text (ex "xxx") inside the 2 inputs, both fields correctly show an error, but you can't click inside the second one to correct the value.

Change History (3)

comment:1 Changed 8 years ago by Liane

Running the test case above without css shows that focus is given to the hidden field.

http://jsfiddle.net/Liane/h4mg5/

comment:2 Changed 8 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed

An implicit LABEL element may not work as a parent of a ValidationTextBox? since 2 INPUT elements are generated and 1 of them is type=hidden which is documented to not work well. Both problems described can be worked around by adding the for/id combination, but leaving the LABEL as the INPUT parent. I don't see an obvious fix.

comment:3 Changed 7 years ago by bill

#17080 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.