Opened 10 years ago

Closed 10 years ago

#14740 closed defect (duplicate)

dojox.socket.LongPoll will not fire events in IE

Reported by: Dmitrim Owned by: Kris Zyp
Priority: undecided Milestone: tbd
Component: Dojox Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

The fire function in dojox.socket.LongPoll? should check for document.createEventObject, instead it tries to create event using document.createEvent("HTMLEvent") which will not work in IE. Basically the fire function should look something like this:

	function fire(type, object, deferred){
		if(socket["on" + type]){
            var event;
            if (document.createEventObject){
                event = document.createEventObject();
            }
            else{
                event = document.createEvent("HTMLEvents");
                event.initEvent(type, false, false);
            }
	        dojo.mixin(event, object);
		event.ioArgs = deferred && deferred.ioArgs;
		socket["on" + type](event);
        }

Change History (2)

comment:1 Changed 10 years ago by Adam Peller

Owner: changed from Adam Peller to Kris Zyp
Status: newassigned

comment:2 Changed 10 years ago by Kris Zyp

Resolution: duplicate
Status: assignedclosed

Duplicate of #14105.

Note: See TracTickets for help on using tickets.