Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14737 closed defect (fixed)

dijit.form.Button goes out of dijit.TooltipDialog

Reported by: hitex Owned by: David Walsh
Priority: undecided Milestone: 1.8
Component: Website Version: 1.7.1
Keywords: Cc: itorrey
Blocked By: Blocking:

Description

Example can be found in tutorial at http://dojotoolkit.org/documentation/tutorials/1.7/dialogs_tooltips/ under "dijit/TooltipDialog Example".

Tested with latest IE, Firefox and Chrome and bug exists in all of them.

Dirrect link to example: http://dojotoolkit.org/documentation/tutorials/1.7/dialogs_tooltips/demo/ttd-button.html

Change History (6)

comment:1 Changed 8 years ago by bill

Milestone: tbd1.7.2
Owner: set to bill
Status: newassigned

Hmm, I see it, very odd. (BTW, thanks for linking to the example and listing the browsers where it fails.)

Seems like a regression so I'm marking this for 1.7.2.

comment:2 Changed 8 years ago by hitex

Just tested with 1.6.1 - the same problem exists too.

comment:3 Changed 8 years ago by bill

Cc: itorrey added
Component: DijitWebsite
Milestone: 1.7.2tbd
Owner: changed from bill to David Walsh

Ah I see, OK so not a regression, it's just that you can't do nested <button>'s. Changing the tutorial to use a <div> for the outer button fixes the problem:

<div data-dojo-type="dijit.form.DropDownButton">
        <span>Login</span><!-- Text for the button -->
        <!-- The dialog portion -->
        <div data-dojo-type="dijit.TooltipDialog" id="ttDialog">
                <strong><label for="email" style="display:inline-block;width:100px;">Email:</label></strong>
                <div data-dojo-type="dijit.form.TextBox" id="email"></div>
                <br />
                <strong><label for="pass" style="display:inline-block;width:100px;">Password:</label></strong>
                <div data-dojo-type="dijit.form.TextBox" id="pass"></div>
                <br />
                <button data-dojo-type="dijit.form.Button" data-dojo-props="onClick:doAlert" type="submit">Submit</button>
        </div>
</div>

I don't have permission to update that tutorial but assigning to David since he wrote it, and cc'ing Torrey since he's in charge of the website.

comment:4 Changed 8 years ago by David Walsh

Updated on Dojo staging, will ping Torrey to make updates live. Thank you hitex!

comment:5 Changed 7 years ago by David Walsh

Resolution: fixed
Status: assignedclosed

comment:6 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.