Opened 10 years ago

Closed 9 years ago

#14736 closed enhancement (wontfix)

API documentation missing information about namespaces in config.php

Reported by: fbest Owned by: Tom Trenka
Priority: high Milestone: 1.8
Component: Documentation Version: 1.7.1
Keywords: reviewed Cc:
Blocked By: Blocking:

Description

The Documentation about the API does not contain the information that you have to enter your namespace in config.php. Also no information in README file. http://dojotoolkit.org/reference-guide/util/doctools/viewer.html

Attachments (1)

lib.patch (589 bytes) - added by fbest 10 years ago.
patch for the null-thing

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by bill

Owner: set to Tom Trenka
Status: newassigned

Tom, I guess this is for you?

comment:2 Changed 10 years ago by Tom Trenka

Thanks, Bill. Yeah, its for me but I'm not sure I have edit access on the ref-guide docs (been half paying attention to that but not really a lot, since I don't normally work on them).

comment:3 Changed 10 years ago by fbest

if the namespace is not setted up in config.php lib/class-tree.php?v=foo returns something like {

identifier: 'id', label: 'name', items: [{foo},null,{bar}]

} the null causes error in ItemFileReadStore?.js on line 553 so the root items cannot be displayed.

this is caused by caching, (after disabling caching one time everything works).

comment:4 Changed 10 years ago by Tom Trenka

Milestone: tbd1.8
Priority: undecidedhigh

comment:5 Changed 10 years ago by Tom Trenka

Keywords: reviewed added

Changed 10 years ago by fbest

Attachment: lib.patch added

patch for the null-thing

comment:6 Changed 10 years ago by fbest

The patch fixes the thing that NULLs are not added to the output. But if you look deeper you could also fix the real issue: how NULL things could be generated by generate.php?! It would also be nice, if the php files are not so mixed up with CRLF and real LFs.

comment:7 Changed 9 years ago by Colin Snover

Resolution: wontfix
Status: assignedclosed

No longer relevant since this documentation parser is being replaced.

Note: See TracTickets for help on using tickets.