Opened 8 years ago

Closed 8 years ago

#14694 closed defect (fixed)

dojox.mobile.Heading back button regression

Reported by: Eric Wang Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Before dojox.mobile trunk version 27595, A user can use default "back" button which call history.back and back to the latest view.

<h1 data-dojo-type="dojox.mobile.Heading" label="Details" back="Back">


In trunk version 27595, this button is replaced by dojox.mobile.ToolBarButton? and use "moveTo" to transition to the latest view.

<h1 dojoType="dojox.mobile.Heading" back="Home" moveTo="foo">Search Result</h1>

As a user I also need the default history.back as the default action in dojox.app

Change History (2)

comment:1 Changed 8 years ago by ykami

Milestone: tbd1.8
Priority: undecidedhigh
Status: newassigned

oh, I didn't know such a feature existed until now. Looks like dmachi added that long time ago. I'll restore that feature.

comment:2 Changed 8 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [27706]:

Fixes #14694 !strict Restored a back button feature. history.back() is called rather than performing a view transition when moveTo is not specified for Heading.

Note: See TracTickets for help on using tickets.