Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14675 closed defect (invalid)

Dojo build fails with "location" is not defined

Reported by: ebengtso Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: BuildSystem Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Running dojo build fails with:

E:\dojotoolkit\util\buildscripts>java
 -Xms256m -Xmx256m  -cp ../shrinksafe/js.jar;../closureCompiler/compiler.jar;../
shrinksafe/shrinksafe.jar org.mozilla.javascript.tools.shell.Main  ../../dojo/do
jo.js baseUrl=../../dojo load=build
js: uncaught JavaScript runtime exception: ReferenceError: "location" is not defined.

Change History (7)

comment:1 Changed 7 years ago by ebengtso

This issue is a blocker, since I cannot create custom builds! I also tried on unix and have the same response from the build tool.

Running on JDK 1.6

comment:2 Changed 7 years ago by Rawld Gill

Resolution: invalid
Status: newclosed

The command line given seems invalid. The semi-colons in

../shrinksafe/js.jar;../closureCompiler/compiler.jar;../shrinksafe/shrinksafe.jar

should be colons

I tried it replacing the semicolons and it worked fine.

Also, you should try using util/buildscripts/build.sh to avoid this issue all together

comment:3 Changed 7 years ago by ebengtso

Actually the output is from util/build scripts/build.bat but it also happens from build.sh or if I launch from ant. So to me this issue should be reopened

comment:4 Changed 7 years ago by ebengtso

problem is no longer happening on HEAD version

comment:5 Changed 7 years ago by BinaryBlock

Hello.

I am having the same problem. I am using the build.sh on CentOS and getting: js: uncaught JavaScript? runtime exception: ReferenceError?: "location" is not defined. Here is command I am running: "./build.sh --profile ../dojo/demo/demo --release"

What does "ebengtso" mean by "HEAD version"?

This is where I got the version I am running: http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2-src.tar.gz

Help, help?

comment:6 Changed 7 years ago by ath@…

Hi,

I've run into this problem as well.

I am able to use build.sh to create a compressed js/css build on my local machine without a problem. When I script the same build into my server-side build, it fails with the error below. Help would be greatly appreciated. I am not sure what needs to be adjusted.

Below is the error I am getting, and I've included environmental variables for both systems at the end. =============== [WEBROOT]/vendor/assets/javascripts/dojo/dojo.js:237

var locationProtocol = location.protocol,

ReferenceError?: location is not defined

at /opt/anthill3/agent/var/jobs/uRelease/vendor/assets/javascripts/dojo/dojo.js:237:27 at Object.<anonymous> (/opt/anthill3/agent/var/jobs/uRelease/vendor/assets/javascripts/dojo/dojo.js:1787:2) at Module._compile (module.js:446:26) at Object..js (module.js:464:10) at Module.load (module.js:353:31) at Function._load (module.js:311:12) at Array.0 (module.js:484:10) at EventEmitter?._tickCallback (node.js:190:38)

===============

ENVIRONMENTS:

REMOTE BUILD :

JAVA_HOME=/usr/java/jdk PWD=/opt/anthill3/agent/var/jobs/uRelease LD_LIBRARY_PATH=/usr/java/jdk-1.6.0_31-x64/jre/lib/amd64/server:/usr/java/jdk-1.6.0_31-x64/jre/lib/amd64:/usr/java/jdk-1.6.0_31-x64/jre/../lib/amd64 PATH=/sbin:/usr/sbin:/bin:/usr/bin:/opt/anthill3/agent/bin:/opt/sonar-runner-1.1/bin

$ which node

/usr/bin/node

$ node -v

v0.6.18

LOCAL BUILD:

PWD=/Users/ath/tools/anthillPro PATH=/opt/local/bin:/opt/local/sbin:/Users/ath/.rbenv/shims:/Users/ath/.rbenv/bin:/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/git/bin:/usr/local//bin:/Users/ath/tools/jslint4java-2.0.2

$ which node /usr/local/bin/node $ node -v v0.6.18

comment:7 Changed 7 years ago by Colin Snover

Update to 1.7.3 or 1.8. Please do not add replies to this ticket.

Note: See TracTickets for help on using tickets.