Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#14650 closed defect (fixed)

Charting Tooltips on plot2d/Bar are incorrectly placed

Reported by: cjolif Owned by: cjolif
Priority: high Milestone: 1.7.2
Component: Charting Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Charting Tooltips on plot2d/Bar are incorrectly placed

This is already fixed in trunk/1.8 however we might want to fix for 1.7.2 as well.

See #27444.

Attachments (1)

test_14650.html (1.8 KB) - added by cjolif 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by felito

I have a similar issue in ClusteredBars?

demo here

http://jsbin.com/utesoz/2/edit#source

comment:2 Changed 10 years ago by cjolif

Status: newassigned

comment:3 Changed 10 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [27669]:

fixes #14650.

comment:4 Changed 10 years ago by cjolif

Resolution: fixed
Status: closedreopened

This fix introduces a regression. See attached test case. It seems the tooltip on the last bar it no anymore correct after the fix.

Changed 10 years ago by cjolif

Attachment: test_14650.html added

comment:5 Changed 10 years ago by cjolif

Resolution: fixed
Status: reopenedclosed

Actually this is not a "real" regression, indeed the behavior was already this one in 1.6. So we are back to original behavior. It is just that this behavior is not necessarily very intuitive. However the actual positioning work is done by dijit/place not charting so there's not much we can do here.

Last edited 10 years ago by cjolif (previous) (diff)

comment:6 Changed 10 years ago by bill

Description: modified (diff)

Well, you could just add a margin-top: 10px to the style of your chart. In the test file there isn't enough room for a tooltip at the top, which is why it's putting the tooltip at the bottom. I agree it looks bad but I'd consider it a problem with the test file.

Alternately in dojox/charting/axis2d/Tooltip, could modify the logic in process to just use ["above"] where it currently uses ["above", "below"].

comment:7 Changed 10 years ago by cjolif

Thanks Bill for looking at this. I agree this is not really a problem. What was questioning me was that using aroundNode.height (deprecated) vs aroundNode.h I get a different (nicer) behavior.

comment:8 Changed 10 years ago by felito

The same problem still exists in dojo 1.7.2

To reproduce the error (firefox 11, chrome, IE9, ...):

1- download :http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2-src.tar.gz 2- upload to server 3-go to dojos/dojo/charting/tests/test_event2d.html

And you can see the problem.

Last edited 10 years ago by felito (previous) (diff)

comment:9 Changed 10 years ago by cjolif

Ok, I reproduce, actually it is a slightly different issue. This is #15016 which is fixed in 1.7.3. Sorry for all this tooltip issues. If download a nightly (http://archive.dojotoolkit.org/nightly/) you should be able to confirm this is working now. If it is not please let me know.

comment:10 Changed 9 years ago by cjolif

#15540 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.