Opened 7 years ago

Closed 3 years ago

#14641 closed defect (duplicate)

Animation.stop(gotoEnd = true) doesn't fire onEnd event

Reported by: Randy Hudson Owned by: dylan
Priority: high Milestone: 1.11
Component: fx Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

in dojo._base.fx.js

According to the doc:

summary: Stops a running animation. gotoEnd: If true, the animation will end.

But when stop(true) is called, it only fires the onStop event. There should be a way to abort an animation and still have your clean-up callback function invoked. What is the point of stop(true) if it doesn't fire onEnd. I'm forced to hook the same function to both onStop and onEnd.

Change History (2)

comment:1 Changed 3 years ago by dylan

Milestone: tbd1.12
Owner: changed from Bryan Forbes to dylan
Status: newassigned

View consider/review for 1.12.

comment:2 Changed 3 years ago by dylan

Milestone: 1.121.11
Resolution: duplicate
Status: assignedclosed

Duplicate of #15034.
Duplicate of #15034. Keeping the newer bug as it has a bit more code detail.

Note: See TracTickets for help on using tickets.