Opened 7 years ago

Closed 6 years ago

#14634 closed enhancement (fixed)

Reconsider iOS flicker workaround

Reported by: Atsushi Ono Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: Cc: Eric Durocher
Blocked By: Blocking:

Description

There was the iOS flicker issue (#13382) caused by iOS webkit bug. Dojo 1.7/1.7.1 has some workaround code to avoid it, but it's a bit tricky and might cause unexpected behavior. We need to reconsider it to find the better way to avoid the flicker issue.

Change History (7)

comment:1 Changed 7 years ago by ykami

Status: newassigned

comment:2 Changed 7 years ago by ykami

In [27587]:

Refs #14634 !strict. Removed the iOS workaround code, since it turned out that it had unexpected side-effects especially on iPad2.

comment:3 Changed 7 years ago by ykami

Milestone: tbd1.8

comment:4 Changed 7 years ago by Atsushi Ono

When reconsidering this workaround code, we should take care that #14194 would never be reproducible.

comment:5 Changed 7 years ago by Atsushi Ono

We should also take care that #14626 would never be reproducible.

comment:6 Changed 7 years ago by ykami

Cc: Eric Durocher added
Milestone: 1.8tbd

edurocher, if you have any suggestions, please let me know. I have nothing more to do at least in the 1.8 time frame.

comment:7 Changed 6 years ago by ykami

Milestone: tbd1.8
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.