Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#14632 closed enhancement (fixed)

Reconsider Android flicker workaround

Reported by: Atsushi Ono Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

There was the Android flicker issue (#12732) caused by Android webkit bug. Dojo 1.7/1.7.1 has some workaround code to avoid it, but it caused several side effects we had to take care of. We need to reconsider it to find the better way to avoid the flicker issue without side effects.

Attachments (3)

14632.patch (2.1 KB) - added by Atsushi Ono 10 years ago.
[patch][ccla] new workaround code for Android screen flicker issue
14632-2.patch (5.6 KB) - added by Atsushi Ono 10 years ago.
[patch][ccla] updated workaround code
14632-3.patch (693 bytes) - added by Atsushi Ono 10 years ago.
[patch][ccla] patch to skip workaround code in case of "mblCSS3Transition:true"

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by ykami

Milestone: tbd1.8
Status: newassigned

comment:2 Changed 10 years ago by ykami

In [27588]:

Refs #14632 !strict. Removed the android flicker workaround code as the first step.

comment:3 Changed 10 years ago by ykami

In [27610]:

Refs #14632 !strict. Use onorientationchange even for android.

Changed 10 years ago by Atsushi Ono

Attachment: 14632.patch added

[patch][ccla] new workaround code for Android screen flicker issue

comment:4 Changed 10 years ago by Atsushi Ono

I have attached a patch of new workaround code, using "-webkit-transform-style:preserve-3d" instead of "-webkit-transform:translate3d(0,0,0)", which results in almost no side effects on Android 2.x except form button dissappearing issue. This workaround code can be disabled by adding "mblAndroidWorkaround:false" to djConfig / data-dojo-config.

comment:5 Changed 10 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [27819]:

Fixes #14632 !strict Use "-webkit-transform-style:preserve-3d" instead of "-webkit-transform:translate3d(0,0,0)" to mitigate the android flicker issue. Thanks onoat for the patch. It looks much better than what we did in 1.7.

Changed 10 years ago by Atsushi Ono

Attachment: 14632-2.patch added

[patch][ccla] updated workaround code

comment:6 Changed 10 years ago by Atsushi Ono

I have attached a patch of the new workaround code to avoid transition animation flicker. In this patch, "-webkit-transform-style:preserve-3d" style is applied to View's domNode only during transition animation, so it has less side effects than the previous patch. This patch is required for the new Android input field jumping workaround in the task #14633.

comment:7 Changed 10 years ago by ykami

In [28112]:

Refs #14632 !strict. Applies -webkit-transform-style:preserve-3d to View's domNode to avoid transition animation flicker. Thanks onoat for the patch.

Changed 10 years ago by Atsushi Ono

Attachment: 14632-3.patch added

[patch][ccla] patch to skip workaround code in case of "mblCSS3Transition:true"

comment:8 Changed 10 years ago by Atsushi Ono

Attached a patch to skip workaround code when using dojox.css3 transition (when specifying "mblCSS3Transition:true" to data-dojo-config) since it breaks them.

comment:9 Changed 10 years ago by ykami

In [28233]:

Refs #14632 !strict. Skip the workaround code when dojox.css3 transition is used. Thanks onoat for the patch.

Note: See TracTickets for help on using tickets.