Opened 8 years ago

Closed 7 years ago

#14626 closed defect (fixed)

Screen flicker when switch tabs from a tabBar in scrollable view

Reported by: zhangzxm Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: flicker, tabbar, scrollableview Cc: Atsushi Ono
Blocked By: Blocking:

Description

When change tabs from one to another of a tabBar in a scrollable view, the background image will flicker (from top to middle in my test). Tested on iPhone 4.3/iPad 5.0.

Attachments (2)

tabBarTest.html (2.8 KB) - added by zhangzxm 8 years ago.
tabbar_all.png (15.0 KB) - added by zhangzxm 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by zhangzxm

Attachment: tabBarTest.html added

Changed 8 years ago by zhangzxm

Attachment: tabbar_all.png added

comment:1 Changed 8 years ago by bill

Component: GeneralDojoX Mobile
Owner: set to ykami

comment:2 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:3 Changed 8 years ago by Atsushi Ono

Thanks for your report. I confirmed the issue. The root cause of this issue is the workaround code for the iOS flicker issue derived from iOS webkit bug (#13382). We plan to reconsider it in #14634. In the meantime, you can disable it by adding "mblIosWorkaround:false" to your djConfig, so could you please try it?

comment:4 Changed 7 years ago by Atsushi Ono

iOS flicker workaround code was removed from the trunk in #14634 since it had several side effects including this issue, so it is indirectly fixed now.

comment:5 Changed 7 years ago by ykami

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

indirectly fixed.

Note: See TracTickets for help on using tickets.