Opened 7 years ago

Closed 7 years ago

#14625 closed defect (invalid)

dojox.form.Uploader uses different filenames for IE vs other (filenames0 vs filenames[])

Reported by: Bitt Owned by: Mike Wilcox
Priority: high Milestone: tbd
Component: DojoX Form Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

When uploading a (single) file using the regular form for handling the upload (no IFrame or Flash), IE uses different filename than the other browsers (Opera, Chrome FF).

If name: 'UploadName?' then IE will post the part/file as UploadName0, while the others will use UploadName?[].

Change History (2)

comment:1 Changed 7 years ago by Adam Peller

Component: GeneralDojoX Form
Milestone: 1.7.2tbd
Owner: set to Mike Wilcox
Status: newassigned

comment:2 Changed 7 years ago by Mike Wilcox

Resolution: invalid
Status: assignedclosed

That's not a bug, that's how different mechanisms handle file uploads. The server should use this information to know what kind of data it is receiving.

http://livedocs.dojotoolkit.org/dojox/form/Uploader#server-side

Note: See TracTickets for help on using tickets.