Opened 7 years ago

Closed 7 years ago

#14616 closed defect (duplicate)

[patch][CCLA] dojox.form.RangeSlider drag operation on the range interval bar not working

Reported by: mikeb Owned by: dante
Priority: high Milestone: tbd
Component: DojoX Form Version: 1.7.1
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

Steps to reproduce:

1) Go to: http://archive.dojotoolkit.org/nightly/checkout/dojox/form/tests/test_RangeSlider.html

2) Select a range by dragging ends of the vertical range bar

3) move the mouse over the middle of the range interval and try dragging it

Expected result: interval moves as you drag

Actual result: interval jumps to the end of the range slider bar.

The fix is to modify the line 334 in dojox.form.RangeSlider? from this:

mouseOffset = widget._mouseOffset = coordEvent[widget._mousePixelCoord] - abspos[widget._startingPixelCoord] - bar[widget._startingPixelCoord];

to this (fixed):

mouseOffset = widget._mouseOffset = coordEvent[widget._mousePixelCoord] - bar[widget._startingPixelCoord];

Attachments (1)

RangeSlider.patch (665 bytes) - added by mikeb 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by mikeb

Attachment: RangeSlider.patch added

comment:1 Changed 7 years ago by cjolif

Summary: dojox.form.RangeSlider drag operation on the range interval bar not working[patch][CCLA] dojox.form.RangeSlider drag operation on the range interval bar not working

patch is IBM, CCLA.

Last edited 7 years ago by cjolif (previous) (diff)

comment:2 Changed 7 years ago by Douglas Hays

Resolution: duplicate
Status: newclosed

Duplicate of #15493.

Note: See TracTickets for help on using tickets.