Opened 8 years ago

Closed 8 years ago

#14590 closed defect (fixed)

dojox.image.SlideShow problem Dojo 1.7.1

Reported by: domsmasher Owned by: cjolif
Priority: high Milestone: 1.7.2
Component: Dojox Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi, I've some problem with dojox.image.SlideShow? in version 1.7.1. I'm using Chrome on windows seven and the error message is:

Uncaught TypeError?: Object #<Object> has no method 'cache' (anonymous function) _c2 _36 _77 _ec req.injectUrl._107

Example Dojo 1.7.1: http://jsfiddle.net/uUmVT/

Example Dojo 1.6 (no error): http://jsfiddle.net/uUmVT/1/

Change History (8)

comment:1 Changed 8 years ago by Adam Peller

Milestone: tbd1.7.2
Owner: changed from Adam Peller to Shane O'Sullivan

comment:2 Changed 8 years ago by Adam Peller

Looks like an error introduced with the AMD conversion in 1.7. As a workaround, you may be able to use the 1.6 dojox/image/SlideShow widget against the 1.7 base.

comment:3 Changed 8 years ago by cjolif

As far as I can see the SlideShow widget has _not_ been moved to AMD. The problem comes from the fact that in 1.6 dojo.cache was probably available indirectly through another dependency and in 1.7 it must be included explicitly when used. In SlideShow it is used but not required. I suppose adding dojo.require("dojo.cache") should fix the issue (but there might be others...)

Last edited 8 years ago by cjolif (previous) (diff)

comment:4 Changed 8 years ago by bill

I'm just not sure how to test it, I made a test file with async:false and it loads fine. I made a test file with async:true and it gets stuck on the dojo.provide() call, saying that dojo isn't defined.

comment:5 Changed 8 years ago by Colin Snover

Milestone: 1.7.21.7.3

1.7.2 RC released, bumping milestone on remaining tickets.

comment:6 in reply to:  4 Changed 8 years ago by cjolif

Replying to bill:

I'm just not sure how to test it, I made a test file with async:false and it loads fine. I made a test file with async:true and it gets stuck on the dojo.provide() call, saying that dojo isn't defined.

Actually I do reproduce with using http://ajax.googleapis.com/ajax/libs/dojo/1.7.1/dojo/dojo.js not a local dojo. Maybe this is reproducible locally with a built version.

comment:7 Changed 8 years ago by bill

Owner: changed from Shane O'Sullivan to cjolif
Status: newassigned

comment:8 Changed 8 years ago by cjolif

Milestone: 1.7.31.7.2
Resolution: fixed
Status: assignedclosed

This is not reproducible anymore with http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js so it looks like it has been fixed in 1.7.2.

Note: See TracTickets for help on using tickets.