Opened 8 years ago

Closed 7 years ago

#14564 closed defect (wontfix)

build.bat fails depending on release path format

Reported by: Daniel Trang Owned by: Rawld Gill
Priority: high Milestone: tbd
Component: BuildSystem Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

If I run: build profile=mobi action=release releaseDir=G:\mobiBuild\aa
I get a heap exception.

If I run: build profile=mobi action=release releaseDir=G:/mobiBuild/aa
Things are ok.

Extra context info:

G:\mobiBuild exists before the build is called.

G:\mobiBuild\aa does not exists before the build is called.

OS: Windows 7 64-bit Pro.

Java: 1.6.0_22

Thanks.

Change History (3)

comment:1 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 7 years ago by Rawld Gill

Resolution: wontfix
Status: assignedclosed

The problem is with the way you're expressing the command line on windows. Try

releaseDir="G:\\mobiBuild\\aa"

Without the quotes and double backslashes, rhino thinks \m and \a are escaping m and a. This is just a painful intersection of windows and Rhino and there's not much we can do.

Note: See TracTickets for help on using tickets.