Opened 8 years ago

Closed 6 years ago

#14553 closed defect (fixed)

bug in http://dojotoolkit.org/documentation/tutorials/1.6/data_modeling/demo/demo.html

Reported by: Martin Repta Owned by: dylan
Priority: high Milestone: 1.9
Component: Website Version: 1.7.1
Keywords: Cc: Kris Zyp
Blocked By: Blocking:

Description

We have found, that demo http://dojotoolkit.org/documentation/tutorials/1.6/data_modeling/demo/demo.html

does not work in IE

The problem is inside insertBefore method. See line 46 in source code.

rows.splice(i, 0, container.insertBefore(row, rows[i]));

When page is loading, rows is empty and therefore rows[i] returns undefined.

As stated here: https://developer.mozilla.org/En/DOM/Node.insertBefore

insertBefore method can accept null value, but it is actually undefined.

Major browsers except IE can accept also undefined, but IE not, it throws an error.

Patch file is attached.

Attachments (1)

insertBefore.patch (659 bytes) - added by Martin Repta 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Martin Repta

Attachment: insertBefore.patch added

comment:1 Changed 8 years ago by bill

Component: GeneralWebsite
Owner: set to itorrey

comment:2 Changed 7 years ago by ben hockey

Status: newopen

comment:3 Changed 7 years ago by bill

Cc: Kris Zyp added

CC'ing Kris since he wrote that demo.

comment:4 Changed 6 years ago by dylan

Owner: changed from itorrey to dylan
Status: openassigned

comment:5 Changed 6 years ago by dylan

Milestone: tbd1.9
Resolution: fixed
Status: assignedclosed

This has already been fixed.

Note: See TracTickets for help on using tickets.