Opened 8 years ago

Closed 8 years ago

#14548 closed defect (duplicate)

dojox/io/OAuth.js will not build - easy fix

Reported by: kbenjamin Owned by: Adam Peller
Priority: high Milestone: tbd
Component: Dojox Version: 1.7.1
Keywords: build oauth Cc:
Blocked By: Blocking:

Description

Downloading the current dojo-boilerplate and doing a build fails on dojox/io/OAuth.js with an error on line 7:

define([
	"dojo/_base/kernel", // dojo
	"dojo/_base/lang", // mixin
	"dojo/_base/array", // isArray, map
	"dojo/_base/xhr", // formToObject, queryToObject, xhr
	"dojo/dom", // byId
	'''"dojox/encoding/digests/SHA1", // SHA1'''
], function(dojo, lang, array, xhr, dom, SHA1){

The issue is that the define dependency array ends with a comma and that is not supported by Internet Explorer (according to the builder).

Editing the array to remove the trailing comma after SHA1 fixes the problem:

define([
	"dojo/_base/kernel", // dojo
	"dojo/_base/lang", // mixin
	"dojo/_base/array", // isArray, map
	"dojo/_base/xhr", // formToObject, queryToObject, xhr
	"dojo/dom", // byId
	"dojox/encoding/digests/SHA1" // SHA1
], function(dojo, lang, array, xhr, dom, SHA1){

Change History (1)

comment:1 Changed 8 years ago by Adam Peller

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.