Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14526 closed defect (fixed)

Tooltips do not position correctly on charts after scroll

Reported by: zebulonevans Owned by: cjolif
Priority: blocker Milestone: 1.7.2
Component: Charting Version: 1.7.1
Keywords: chart tooltip Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

Steps to reproduce the problem.

  1. Put a bar chart or pie chart on a page with a tooltip.
  2. Mouse over the chart to show the tooltip.
  3. Mouse off the tooltip so it hides
  4. Scroll the page down.
  5. Mouse over the tooltip again

The tooltip will remain in the original position.

Expected Behavior:

The tooltip should appear lower on the page not in the original position.

This was introduced due to ticket #12392 around line 141 in Tooltip.js when this change occurred:

var lt = dojo.coords(this.chart.node, true);

to

var lt = this.chart.getCoords();

Attachments (2)

20.png (68.8 KB) - added by zebulonevans 7 years ago.
Initial Tooltip Mouseover
37.png (66.8 KB) - added by zebulonevans 7 years ago.
Tooltip Mouseover After Scroll

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by zebulonevans

Attachment: 20.png added

Initial Tooltip Mouseover

Changed 7 years ago by zebulonevans

Attachment: 37.png added

Tooltip Mouseover After Scroll

comment:1 Changed 7 years ago by Adam Peller

Component: DojoxCharting
Description: modified (diff)
Owner: changed from Adam Peller to Eugene Lazutkin

comment:2 Changed 7 years ago by cjolif

Milestone: tbd1.7.2
Owner: changed from Eugene Lazutkin to cjolif
Priority: highblocker
Status: newassigned

comment:3 Changed 7 years ago by cjolif

In [27759]:

refs #2929, #14702, #14526.

  • Having lighter charts especially for mobile (inherit _WidgetBase, have SimpleTheme? vs Theme). Also fix some AMD dependencies to minimize them.
  • Introduce a parameter to recompute offsets after calling updateData on series
  • fix a regression on tooltip position after scroll.

!strict.

comment:4 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [27761]:

fixes #14526. In 1.7 branch. !strict.

comment:5 Changed 7 years ago by cjolif

#14847 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.