Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#14503 closed defect (fixed)

[regression] connect to onpropertychange fails on IE9/quirks

Reported by: bill Owned by: Kris Zyp
Priority: high Milestone: 1.7.2
Component: Events Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

See attached test case, running on IE9. It will give an error in the console when it tries to

dojo.connect(dojo.body(), "onpropertychange", ..);

Worked in 1.6.

If the problem doesn't reproduce make sure in the developer console that browser mode and document mode are set to their defaults:

browser and document mode screenshot (from IE developer console, F12 key)

Attachments (2)

mode.gif (7.8 KB) - added by bill 10 years ago.
browser and document mode screenshot (from IE developer console, F12 key)
onpropertychange.html (417 bytes) - added by bill 10 years ago.
test case

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by bill

Attachment: mode.gif added

browser and document mode screenshot (from IE developer console, F12 key)

Changed 10 years ago by bill

Attachment: onpropertychange.html added

test case

comment:1 Changed 10 years ago by bill

Note that the error has nothing to do with connecting to dojo.body(); it happens for any node.

comment:2 Changed 10 years ago by Kris Zyp

Resolution: fixed
Status: newclosed

In [27490]:

Reverse order of setting dispatcher variable and property to avoid error with IE's immediate firing of propertychange event when the event handler for that event is set, fixes #14503 !strict

comment:3 Changed 10 years ago by bill

Milestone: tbd1.8

comment:4 Changed 10 years ago by bill

BTW, since this is a regression you might want to backport it to the 1.7 branch. OTOH it seems like an uncommon use case. TBH I'm surprised that anyone is connecting to onpropertychange, but apparently they are.

comment:5 Changed 10 years ago by bill

Kris, this looks like a safe change, you don't mind if I backport it to 1.7 do you?

comment:6 Changed 10 years ago by Kris Zyp

No, that's fine, go for it.

comment:7 Changed 10 years ago by bill

Milestone: 1.81.7.2

Oh, actually turns out you already did it, in [27494], just didn't show up here.

comment:8 Changed 9 years ago by bill

In [30344]:

add test for #14503 to 1.7 branch, refs #14503 !strict

comment:9 Changed 9 years ago by bill

Note that this isn't an issue on 1.6 since dojo/on first appeared in 1.7.

Note: See TracTickets for help on using tickets.