Opened 8 years ago

Closed 8 years ago

#14489 closed defect (fixed)

Dojox Mobile Combo Box vibrating issue in FF

Reported by: Paul Christopher Owned by: Douglas Hays
Priority: low Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Description:

The popover of an expanded combo box within a scrollable view starts to vibrate once the scrollable view has been scrolled.

Steps to reproduce the issue: Open dojox/mobile/tests/test_ComboBox-ScrollableView.html with Firefox 8. Click into the combo box's input field. The popup shows up and remains still. Now scroll the scrollable view down. After scrolling has finished, the combo box starts to vibrate and tremble.

Discussion Only a cosmetic issue I wanted to report for the sake of completeness. Keep up the good work! I enjoy using the dojo toolkit very much.

Change History (4)

comment:1 Changed 8 years ago by ykami

Owner: changed from ykami to Douglas Hays

comment:2 Changed 8 years ago by Douglas Hays

Paul, I tested on trunk [27679] using Firefox 9 and I don't think I see any shaking. Scrolling the dropdown is a little jittery but after the animation stops then it seems to be stationary. Can you verify if this is still a problem or not.

comment:3 Changed 8 years ago by Douglas Hays

Milestone: tbd1.8
Status: newassigned

I see it now.

comment:4 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [27692]:

Fixes #14489. Firefox likes to move things in partial pixel increments and this was causing the problem. Changed reposition check to ignore < 1 pixel.

Note: See TracTickets for help on using tickets.