Opened 7 years ago

Closed 7 years ago

#14485 closed defect (fixed)

Dojox Mobile Combobox : Popup does not show up when clicking into it

Reported by: Paul Christopher Owned by: Douglas Hays
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Description:

When clicking into a combo box, the selection list/ popup is not always displayed. Solely the input field gains focus.

Steps to reproduce the issue:

Open dojox/mobile/tests/test_FormControls.html on a desktop browser such as FF 8, Safari 5, IE 9. Click into the input field of the combo box. The input field gains focus, but the popover is not displayed and/or gets closed immediately. Test is several times with different browsers. Click somewhere else so as to remove the focus again (e.g. by clicking into the text box widget below). Return to the combo box by clicking into it. Do it several times. Sometimes, but not always, the popup is displayed. Thus: Something seems to be broken on desktop browsers for some reason. The popup does not reliably get displayed.

Affected browsers:

Happens to me in Firefox 8.0.1, Safari 5.1.2, IE 9 on Win 7 platform

Change History (3)

comment:1 Changed 7 years ago by ykami

Owner: changed from ykami to Douglas Hays

comment:2 Changed 7 years ago by Douglas Hays

Milestone: tbd1.8
Status: newassigned

comment:3 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [27681]:

Fixes #14485. Make sure touch.release only closes the dropdown after a touch.press is recorded in order to avoid rapid open/close scenarios. Also allow onclick to process before mouseup.

Note: See TracTickets for help on using tickets.