Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14472 closed defect (fixed)

[regression] stroke of PlotKit theme can't be overriden anymore

Reported by: cjolif Owned by: cjolif
Priority: high Milestone: 1.8
Component: Charting Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

This can easily be created with the test case dojox/charting/tests/test_chart2d.html

The problem happens whenever you have a theme set. So add a theme to "Stacked bars, no axes, custom strokes and fills.":

... description: "Stacked bars, no axes, custom strokes and fills.", makeChart: function(node){ (new dojox.charting.Chart(node)).setTheme(dojox.charting.themes.PlotKit?.green). addPlot("default", {type: "StackedBars?"}). ...

Then load the test and notice that the outline of the bars are now white instead of red and blue.

This used to work in 1.4.x. Not anymore starting with 1.5

Change History (4)

comment:1 Changed 8 years ago by cjolif

Even if that is a regression, considering that this behavior is here since 3 releases now (1.5, 1.6, 1.7) I will only fix that in 1.8 at least for now. One can workaround if needed by not using PlotKit theme or extending it.

Last edited 8 years ago by cjolif (previous) (diff)

comment:2 Changed 8 years ago by cjolif

Milestone: tbd1.8

comment:3 Changed 8 years ago by cjolif

Resolution: fixed
Status: newclosed

In [27424]:

Fixed #14472.

comment:4 Changed 8 years ago by cjolif

In [27693]:

refs #14472.

Note: See TracTickets for help on using tickets.