Opened 7 years ago

Closed 7 years ago

#14460 closed defect (duplicate)

dojox.data.jsonRestStore doesn't send an onNew notification

Reported by: Jean-Rubin Leonard Owned by: Kris Zyp
Priority: high Milestone: tbd
Component: DojoX Data Version: 1.7.1
Keywords: dojox.data.JsonRestStore onNew notification _onItemChildrenChange Cc:
Blocked By: Blocking:

Description

dijit.Tree has this private method that is called when an item is changed: _onItemChildrenChange. This method happens after a long list of events triggered by the onNew notification. ItemFileWriteStore? calls the onNew notification at the end of its newItem event.

dojox.data.JsonRestStore? doesn't. The end result of this is that the tree doesn't detect that one of its node has an extra children and the expando is not shown. Thanks for correcting the behavior.

Change History (3)

comment:1 Changed 7 years ago by Jared Jurkiewicz

Owner: changed from Jared Jurkiewicz to Kris Zyp

comment:2 Changed 7 years ago by Jean-Rubin Leonard

Can be closed. This is a duplicate of #9801

comment:3 Changed 7 years ago by Kris Zyp

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.