Opened 7 years ago

Closed 7 years ago

#14458 closed defect (fixed)

[regression] getBox() incorrectly including scrollbar size

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.7.2
Component: Core Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

Run test_ComboBox. Open the popup for the Dijit widget list. Resize the browser window horizontally so that the popup scrollbar is partially obscured by the browser window scrollbar. Close the popup and reopen. It's still obscured. It should have aligned to the right edge of the textbox. The problem is that window.getBox().w is too large by the size of the vertical scrollbar.

Change History (3)

comment:1 Changed 7 years ago by Douglas Hays

In [27391]:

Refs #14458, #12851. Don't use window.innerHeight/Width on desktops since the scrollbar size is included, but continue to use it for mobile. !strict

comment:2 Changed 7 years ago by Douglas Hays

Summary: getBox() incorrectly including scrollbar size[regression] getBox() incorrectly including scrollbar size

This worked OK in 1.6.1.

comment:3 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [27423]:

Fixes #14458. Backport [27391] to branch/1.7 and shave some bytes. !strict

Note: See TracTickets for help on using tickets.