Opened 7 years ago

Closed 7 years ago

#14448 closed defect (duplicate)

Select with store in a Repeat does no set initial value properly

Reported by: Stefan Meyer Owned by: Ed Chatelain
Priority: high Milestone: 1.8
Component: DojoX MVC Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

I had to add this to _patches.js:

wb.prototype.startup = function(){ if (this.declaredClass=="dijit.form.Select" && this.get("store")){

this._loadingStore=true;

} ..

Otherwise when the value is set from the model, then _pendingValue is undefined an will thus not be set to the model's value. Later the value is set to the first entry in the options.

Change History (2)

comment:1 Changed 7 years ago by Ed Chatelain

I will try to recreate it, I believe it is a problem with dijit.form.Select.

Last edited 7 years ago by Ed Chatelain (previous) (diff)

comment:2 Changed 7 years ago by Ed Chatelain

Milestone: tbd1.8
Resolution: duplicate
Status: newclosed

Duplicate of #13372.
This was fixed by 13372.

Note: See TracTickets for help on using tickets.