Opened 8 years ago

Closed 8 years ago

#14442 closed defect (fixed)

TimePicker has too few entries near midnight

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.6.2
Component: Dijit - Form Version: 1.6.1
Keywords: dohfail Cc:
Blocked By: Blocking:

Description (last modified by bill)

Load dijit/tests/form/test_TimeTextBox.html.
Change the time for "24 Hour Time with 1 Hour TimePicker" to 12:00:00.
Open the popup and there's only 1 time 00:00:00 shown.

Attachments (1)

14442.patch (1.5 KB) - added by Douglas Hays 8 years ago.
fix - part 2

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Douglas Hays

In [27365]:

Refs #14442. If the # of entries returned is too few, then add more entries in the other direction to make the total the correct number. Add automated _TimePicker tests.

comment:2 Changed 8 years ago by bill

I guess you meant to mark the milestone as 1.8? Or you will check in backports to 1.7/ and 1.6/ later? (I know that 1.7.1 is in code freeze now, theoretically the branch will be open again on Monday.)

comment:3 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [27425]:

Fixes #14442. Backport [27365] to 1.7 and 1.6 since the _TimePicker is hard to use around midnight.

comment:4 Changed 8 years ago by bill

Description: modified (diff)
Resolution: fixed
Status: closedreopened

After this change the TimeTextBox.html test is failing:

	_AssertFailure: assertEqual() failed:
	expected
		8
	but got
		10

 with hint: 
		# of items in drop down
...
LOG: debug: FAILED test: partial input 2953 ms

comment:5 Changed 8 years ago by bill

Keywords: dohfail added

Changed 8 years ago by Douglas Hays

Attachment: 14442.patch added

fix - part 2

comment:6 Changed 8 years ago by Douglas Hays

bill, please review the patch. Also, I think this should go into 1.7.2 (and 1.6.x) if you approve since it's a new regression caused by the previous fix. Also, I fixed a serious problem where clicking a date/time dropdown item only set the textbox string value and didn't set the widget date value. I don't understand why this was like that. Fixing that problem also helped fix another problem where once you type in a partial date/time, that filter remained until the widget value was set with a blur, but now its reset on dropdown selection. All relevant tests (date/time/inlineeditbox) seem to pass now.

comment:7 Changed 8 years ago by bill

The patch fixes the problem for me and the changes all look reasonable. I don't really know that TimePicker code well enough to say more. I agree it should go into 1.7.2 and 1.6.2.

comment:8 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

In [27875]:

Fixes #14442. Reset filterString after successful set value of time/date. Fix _TimePicker's time search to not return duplicate times caused by [27425].

Note: See TracTickets for help on using tickets.