Opened 7 years ago

Closed 7 years ago

#14427 closed defect (duplicate)

dojox.mvc.Group prevents CSS style to be applied as expected

Reported by: Eric Wang Owned by: Ed Chatelain
Priority: high Milestone: 1.8
Component: DojoX MVC Version: 1.7.0
Keywords: todoapp Cc:
Blocked By: Blocking:

Description

dojox.mvc.Group prevents CSS style to be applied as expected. a reason is dojox.mvc.Group as the parent of dojox.mobile widgets and the mobile widgets cannot find its original parent.

Change History (2)

comment:1 Changed 7 years ago by cjolif

Keywords: todoapp added

comment:2 Changed 7 years ago by Ed Chatelain

Resolution: duplicate
Status: newclosed

Duplicate of #14423.
The dojox.mvc.Group can be removed to avoid the problem, with code like this:

<ul data-dojo-type="dojox.mobile.RoundRectList?" id="repeatId1" select="single"

data-dojo-mixins="dojox.mvc.Repeat" data-dojo-props="exprchar:'#',

ref:'model1.Results'">

<li id="configure_itemmix1#{this.index}" class="mblVariableHeight"

data-dojo-type="dojox.mobile.ListItem?" data-dojo-props="label: dojox.mvc.at('rel:#{this.index}.First', 'value'),

checked: dojox.mvc.at('rel:#{this.index}.Checked', 'value')">

</li>

</ul>

See ticket #14423 for details.

Note: See TracTickets for help on using tickets.