Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14421 closed defect (fixed)

Page layout is screwed up when popping up the device keyboard

Reported by: remy314 Owned by: Eric Durocher
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.0
Keywords: keyboard, todoapp Cc: Atsushi Ono
Blocked By: Blocking:

Description

When the keyboard of device(Galaxy P-1000) popping up at the first time, the page layout is screwed up. This defect can't be reproducted on desktop browser. Please visit the attached test page through mobile browser.(I used Galaxy P-1000). If I remove 'btnClass="mblDomButtonBluePlus"' defined on each ListItem? or change the 'dojox.mobile.ScrollableView?' to 'dojox.mobile.View', the bug will disappear.

Attachments (2)

Keyboard-bug.png (81.9 KB) - added by remy314 8 years ago.
keyboard.html (4.2 KB) - added by remy314 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by remy314

Attachment: Keyboard-bug.png added

Changed 8 years ago by remy314

Attachment: keyboard.html added

comment:1 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:2 Changed 8 years ago by bill

Milestone: tbd

comment:3 Changed 8 years ago by Atsushi Ono

Thanks for attaching test page. I tried it on Galaxy Tab, Nexus S and Motorola Xoom, but I could not reproduce the issue like your screen shot. Could you give us more detail?

  • What version of Dojo are you using? The released version of Dojo 1.7.0?
  • What version of Android OS is your Galaxy P-1000? Android 2.2?
  • Can you always reproduce the issue on your Galaxy P-1000? or only occasionally?
  • Can you reproduce it on other Android devices? (if you have)

comment:4 Changed 8 years ago by cjolif

Keywords: todoapp added

comment:5 Changed 8 years ago by remy314

Sorry for reply late.

What version of Dojo are you using? The released version of Dojo 1.7.0? dojo 1.7.0

What version of Android OS is your Galaxy P-1000? Android 2.2? android 2.3.6

Can you always reproduce the issue on your Galaxy P-1000? or only occasionally? always

Can you reproduce it on other Android devices? (if you have) Can also be reproduce on Galaxy S2(android 2.3.6), but can not reproduct on xoom(android 4.0.3)

comment:6 Changed 8 years ago by Atsushi Ono

Thanks for your information. Although we still cannot reproduce the issue on my Nexus S (2.3.6) yet with the latest code, we have just committed several Android specific codes (#14632, #14633) this week, so these updates may indirectly fix the issue. Could you please try it again with the latest trunk code? Thanks.

comment:7 Changed 8 years ago by Eric Wang

It is happened when loading a mobile page in Android Webview, not in Android browser.

comment:8 Changed 7 years ago by remy314

This defect can be reproduced every time on dojo 1.7.2 release version.

comment:9 Changed 7 years ago by cjolif

Owner: changed from ykami to Eric Durocher
Status: newassigned

comment:10 in reply to:  8 Changed 7 years ago by Eric Durocher

Resolution: fixed
Status: assignedclosed

Replying to remy314:

This defect can be reproduced every time on dojo 1.7.2 release version.

Yes I confirm that I reproduce the problem by building the sample as a Phonegap application with Dojo 1.7.2 on Galaxy Tab P-1000. I do not reproduce any more with trunk though, the page works fine there, so as onoat said this has probably been fixed indirectly.

I am closing this, feel free to reopen if you still reproduce on trunk.

comment:11 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.