Opened 7 years ago

Closed 6 years ago

#14331 closed defect (fixed)

highlighting link and pressing link toolbar button, dialog URL field blank (IE)

Reported by: bill Owned by: Jared Jurkiewicz
Priority: blocker Milestone: 1.8
Component: Editor Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

On IE (tested on IE8 and IE9):

  1. load test_LinkDialog.html
  2. highlight the entire "This is an example ..." link in the editor
  3. press the "link" toolbar button

The TooltipDialog appears but the URL TextBox is blank. On other browser it shows the current URL of the link. Also note that IE shows the URL of the link the second time you try this experiment.

Change History (9)

comment:1 Changed 7 years ago by Jared Jurkiewicz

Owner: set to Jared Jurkiewicz
Resolution: fixed
Status: newclosed

In [27235]:

Fix up IE selection. What a royal pain. It likes to grab too much which makes it a nightmare to determine you selected a link inside a div. fixes #14331

comment:2 Changed 7 years ago by Jared Jurkiewicz

Milestone: 1.8

comment:3 Changed 7 years ago by bill

In [27241]:

Add tests for #14331, although it's hard to duplicate the actual failure condition when a user selects a link with the mouse. Also fixing spacing etc. in selection.js. Refs #14331 !strict.

comment:4 Changed 6 years ago by Douglas Hays

Milestone: 1.8
Priority: highblocker
Resolution: fixed
Status: closedreopened

This is causing a serious regression with IE9. Load test_Editor.html and scroll down to the Editor labelled "Optional toolbar buttons". Click to open the "Insert Image" TooltipDialog?, enter a URL and click Set. The TooltipDialog? does not close anymore no matter what you do.

comment:5 Changed 6 years ago by Douglas Hays

Milestone: 1.8.2

comment:6 Changed 6 years ago by bill

Milestone: 1.8.21.8.3

1.8.2 is released so setting to next milestone for the fix.

I ran the test on IE10. It's failing on the sel.getRangeAt(0) call below, with and IndexSizeError exception:

if(has("ie")){
	// IE is difficult to select the element in, using the range unified
	// API seems to work reasonably well.
	var sel = rangeapi.getSelection(this.editor.window);
	var range = sel.getRangeAt(0);

The rangeapi module has a special code path for older versions of IE, but for IE10 at least it's following the standard code path (same as for chrome and firefox). Not sure if that's related.

Anyway, it looks like we should just be checking sel.rangeCount. If it's 0 then we should skip the rest of the code.

comment:7 Changed 6 years ago by bill

In [30187]:

Fix exception trying to adjust range when nothing is selected, fixes regression from [27235] on trunk, refs #14331 !strict.

comment:8 Changed 6 years ago by bill

In [30188]:

Fix exception trying to adjust range when nothing is selected, fixes regression from [27235] on 1.8 branch, refs #14331 !strict.

comment:9 Changed 6 years ago by bill

Milestone: 1.8.31.8
Resolution: fixed
Status: reopenedclosed

For documentation purposes, I listed this regression as a separate ticket: #16477.

Note: See TracTickets for help on using tickets.