Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#14323 closed defect (fixed)

editor exception on initialization in IE9 (in some cases)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.7.5
Component: Editor Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

In test_FullScreen.html (or the associated Fullscreen.html robot test), I get an exception on initialization of editor3. The iframe.src references "parent", which looks like a normal window object but doesn't contain the dijit object (or dojo or dojox), so it's not the window object associated with the browser top level window.

Further, if you go past that stage, the iframe gets an exception in the onLoad handler because frameElement is null.

Strangely, this all resolves itself later because the editor iframe revaluates the src parameter, and then reruns the onload handler.

But it's still problematic since it causes an exception, which either pops up a dialog or appears at the bottom of the browser, depending on settings.

Change History (4)

comment:1 Changed 7 years ago by bill

Note: this occurred on my Windows 7 pro x64bit VM, with 64 bit IE, and Windows 7 home x32bit thinkpad when the IE9 debugger is turned on, but doesn't reproduce on my Windows 7 home VM with 32 bit IE Seems random.

comment:2 Changed 7 years ago by bill

Owner: set to bill
Resolution: fixed
Status: newclosed

In [27128]:

Workaround IE9 bug where iframe is initialized twice, and the first time "parent" points to a phantom window object without dijit defined, and "frameElement" is null, fixes #14323 !strict. Also removes use of dijit global, fixes #14324 !strict.

comment:3 Changed 6 years ago by bill

In [30261]:

backport [27128] to 1.7, fixing editor initialization problems on IE9/IE10, fixes #14323, #14324 on 1.7 branch !strict.

comment:4 Changed 6 years ago by bill

Milestone: 1.81.7.5
Note: See TracTickets for help on using tickets.