Opened 8 years ago

Closed 4 years ago

#14298 closed defect (patchwelcome)

missing loader/builder documentation pages

Reported by: bill Owned by: Rawld Gill
Priority: high Milestone: 1.13
Component: Documentation Version: 1.7.0
Keywords: Cc: Kitson Kelly, Colin Snover, phiggins
Blocked By: Blocking:

Description (last modified by bill)

buildSystem.rst, build/index.rst, profileQRef.rst and qref.rst link to a number of pages that don't exist:

  • build/htmltoprofile
  • build/relocatingpackages
  • build/legacybackcompat
  • build/transforms/dojoreport
  • build/transforms/hasreport
  • build/transforms/insertsymbols
  • build/transforms/optimizecss
  • build/transforms/read
  • build/transforms/writecss

amd.rst references:

  • dojo/load
  • dojo/loadinit

Change History (15)

comment:1 Changed 8 years ago by bill

Description: modified (diff)

comment:2 Changed 8 years ago by bill

Description: modified (diff)
Summary: builtSystem.rst dead linksmissing loader/builder documentation pages

comment:3 Changed 8 years ago by Rawld Gill

Milestone: 1.8
Status: newassigned

comment:4 Changed 7 years ago by bill

#15460 is a duplicate of this ticket.

comment:5 Changed 7 years ago by bill

Description: modified (diff)

comment:6 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

comment:7 Changed 7 years ago by bill

Resolution: fixed
Status: closedreopened

Is this really fixed? I checked the first one, and buildSystem.rst still accesses a non-existant build/htmltoprofile.

comment:8 Changed 7 years ago by bill

Cc: Kitson Kelly Colin Snover phiggins added

Maybe the rstWiki site is broken again, I guess it's a standing bug that it can't handle new files. Kitson, Colin, or Peter, can you fix?

comment:9 Changed 7 years ago by Colin Snover

I added files to the repo but that isn’t really a “fix” for the problem

comment:10 Changed 7 years ago by bill

Right, the real issue is filed as https://github.com/phiggins42/rstwiki/issues/20. Thanks for adding the files.

Rawld, looks like you fixed some of the broken links but I'm still getting these build errors:

/Volumes/Data/workspace/rstwiki/export/source/build/buildSystem.rst:94: WARNING: undefined label: build/htmltoprofile (if the link has no caption the label must precede a section header)
/Volumes/Data/workspace/rstwiki/export/source/build/buildSystem.rst:100: WARNING: undefined label: build/relocatingpackages (if the link has no caption the label must precede a section header)
/Volumes/Data/workspace/rstwiki/export/source/build/buildSystem.rst:103: WARNING: undefined label: build/legacybackcompat (if the link has no caption the label must precede a section header)
/Volumes/Data/workspace/rstwiki/export/source/build/buildSystem.rst:943: WARNING: undefined label: build/transforms/writecss (if the link has no caption the label must precede a section header)
/Volumes/Data/workspace/rstwiki/export/source/build/profileQRef.rst:299: WARNING: undefined label: build/transforms/writeoptimize (if the link has no caption the label must precede a section header)
/Volumes/Data/workspace/rstwiki/export/source/build/qref.rst:331: WARNING: undefined label: build/transforms/writeoptimize (if the link has no caption the label must precede a section header)
}}}}

comment:11 Changed 7 years ago by Kitson Kelly

comment:12 Changed 7 years ago by Kitson Kelly

Ok, I have fixed the issue in rstwiki. I will ping rchady and get him to update the website with the new code.

comment:13 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 has been tagged; moving all outstanding tickets to next major release milestone.

comment:14 Changed 6 years ago by Rawld Gill

Status: reopenedassigned

comment:15 Changed 4 years ago by dylan

Milestone: 2.01.12
Resolution: patchwelcome
Status: assignedclosed

Given that no one has shown interest in creating a patch in the past 4+ years, I'm closing this as patchwelcome.

Note: See TracTickets for help on using tickets.