Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14296 closed defect (fixed)

[regression] dojo.getNodeProp is mis-aliased as dojo.getPropNode in 1.7's dojo/_base/html

Reported by: Kenneth G. Franqueiro Owned by: Kenneth G. Franqueiro
Priority: high Milestone: 1.7.1
Component: Core Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

In previous versions of Dojo, dojo/_base/html.js defines the dojo.getNodeProp function. In 1.7, this is now exposed via the getNodeProp method of the dojo/dom-attr module, and there is supposed to be an alias in dojo/_base/html; however, that alias mistakenly maps to dojo.getPropNode instead of dojo.getNodeProp.

(This was originally confusing me while reviewing the reference docs; turns out we have a page for getNodeProp but we were linking to getPropNode possibly due to the typo in the alias.)

Change History (2)

comment:1 Changed 8 years ago by Kenneth G. Franqueiro

Resolution: fixed
Status: newclosed

In [27109]:

Fix dojo.getNodeProp alias; fixes #14296 on trunk

comment:2 Changed 8 years ago by Kenneth G. Franqueiro

In [27110]:

Fix dojo.getNodeProp alias; fixes #14296 on 1.7 branch

Note: See TracTickets for help on using tickets.