Opened 2 years ago

Closed 16 months ago

#14295 closed defect (wontfix)

Calendar: month drop down's right border not visible in quirks mode

Reported by: SeaAndHill Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: DateTextBox 1.6 Cc:
Blocked by: Blocking:

Description

Hi,

Recently i will upgrade dojo library from 1.0 to 1.6.1, i encounter a problem with 1.6 in IE 8 and the OS in Window xp.
The problem is popuu widgets Month right border not visible in IE 8 ,because the html doctype is <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN"> and not <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01EN" "http://www.w3.org/TR/html4/strict.dtd">.
Can someone give any advice or is it a bug?

Attachments (3)

DateTextBox_bug.jpg (18.0 KB) - added by SeaAndHill 2 years ago.
the screenshot with bug
Dojo_DateTextBox_bug.html (1.1 KB) - added by SeaAndHill 2 years ago.
the html source with bug
Dojo_DateTextBox.html (1.1 KB) - added by SeaAndHill 2 years ago.
the html source work normal

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by SeaAndHill

the screenshot with bug

Changed 2 years ago by SeaAndHill

the html source with bug

Changed 2 years ago by SeaAndHill

the html source work normal

comment:1 Changed 2 years ago by bill

  • Component changed from General to Dijit
  • Summary changed from DateTextBox popup widgets right border not visible for month IE 8 to Calendar: month drop down's right border not visible for IE8, quirks mode

Looks like a bug, probably solvable with some CSS changes.

comment:2 Changed 2 years ago by bill

  • Milestone set to tbd

comment:3 Changed 16 months ago by bill

  • Resolution set to wontfix
  • Status changed from new to closed
  • Summary changed from Calendar: month drop down's right border not visible for IE8, quirks mode to Calendar: month drop down's right border not visible in quirks mode

It shows up a bit better with claro than with tundra. Probably we won't fix this since we will desupport quirks mode eventually.

Note: See TracTickets for help on using tickets.