Opened 8 years ago

Closed 7 years ago

#14292 closed defect (wontfix)

IE7, dijit, claro: button mouse-over hides text in textboxes in a table on a dialog

Reported by: bdd@… Owned by: Douglas Hays
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

In IE7, with the Claro theme, mousing over a dijit.form.Button causes text inside a dijit.form.TextBox? to be hidden when the TextBox? is nested in a table nested in a dijit.Dialog and the Button is not in the same table. Does not reproduce in IE8 compatibility mode.

Overriding "position: relative" from dijitInputContainer with "postion: static" seems to fix the issue.

Attachments (1)

example.html (1.2 KB) - added by bdd@… 8 years ago.
Example of text hide issue

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by bdd@…

Attachment: example.html added

Example of text hide issue

comment:1 Changed 8 years ago by bill

Component: Dijit - LnFDijit - Form
Owner: set to Douglas Hays

Sounds similar to (but not the same bug as) #13493. I thought I had seen this problem before, in another ticket, but can't find it now.

comment:2 Changed 7 years ago by bill

Milestone: tbd

comment:3 Changed 7 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed

This is a problem only for IE6/7 in strict mode. We can't change dijitInputContainer to position:static since the placeHolder code needs the relative parent for positioning. However, an easier workaround is for you to add position:relative to your TABLE. Given the easy workaround, and that we'd like to desupport IE6/7 asap, and that it works in IE8 compat view, I think this is a wontfix.

Note: See TracTickets for help on using tickets.