Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14287 closed enhancement (fixed)

Tree: add back expandAll() method

Reported by: bill Owned by: bill
Priority: high Milestone: 1.8
Component: Dijit Version: 1.7.0
Keywords: Cc:
Blocked by: Blocking:

Description

[20529] removed Tree's expandAll() method in favor of a flag to the constructor, but it turns out people want to expand/contract the Tree dynamically. So add that code back in.

Change History (2)

comment:1 Changed 6 years ago by bill

  • Owner set to bill
  • Resolution set to fixed
  • Status changed from new to closed

In [27124]:

Add expandAll() and collapseAll() methods, and rewrite _expandNode() for more sane usage of Deferreds (fixing a bug my new regression tests found), fixes #14287 !strict.

comment:2 Changed 6 years ago by bill

In [27133]:

IE9 needs longer timeout for test, refs #14287

Note: See TracTickets for help on using tickets.