Opened 8 years ago

Closed 8 years ago

#14270 closed defect (duplicate)

Problem in form Validation with firefox and rtl

Reported by: ms_eng50 Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit - Form Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

A problem occurred with from validation in firefox browser and rtl, which is the error message appeared at the end of the page not to to the right of the control where it suppose to be.

PS: it works fine with IE8 and Google Chrome

Attachments (2)

error.jpg (25.1 KB) - added by ms_eng50 8 years ago.
Login.htm (4.2 KB) - added by ms_eng50 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by ms_eng50

Attachment: error.jpg added

Changed 8 years ago by ms_eng50

Attachment: Login.htm added

comment:1 Changed 8 years ago by bill

Milestone: 1.7
Resolution: fixed
Status: newclosed

I can reproduce that problem on test_Dialog.html?dir=rtl in 1.6 (on firefox), but it works correctly in 1.7. I remember fixing this, although I forget the exact code change.

comment:2 Changed 8 years ago by ms_eng50

Resolution: fixed
Status: closedreopened

Since 1.7 still beta, and I am already using 1.6.1 and to be honest I don't want to face different problems on 1.7 because I need all my html files to be right-to-left, if you please find the problem in 1.6.1 I'll be appreciated

comment:3 Changed 8 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill
Status: reopenednew

comment:4 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

1.7 was released three weeks ago and is available at http://download.dojotoolkit.org/. It just hasn't been announced yet.

The problem listed here is #13636 and was fixed in [26167].

Note: See TracTickets for help on using tickets.